How to update to Joomla 4?




Looking for how to update to Joomla 4? In this tutorial, we are going to show you the easiest and fastest way to update a website with installed Balbooa Extensions to Joomla 4. All you need to do is to be attentive and follow the step-by-step instruction.




How to update your sites to Joomla 4?


Requirements for Joomla 4:


  • PHP - 7.4 +
  • MySQL - 5.6 +
  • Before you start upgrading your site to Joomla 4 - make a backup of your site



1. Update your site to Joomla 3.10 (if you haven't done it yet).

2. Update all Joomla extensions.


* Absolutely all 3rd-party extensions installed on your site must be compatible with Joomla 4. See information on developer sites. Uninstall extensions incompatible with Joomla 4.

  • If any of the 3rd-party extensions on your site are not compatible with Joomla 4, you will get Error 500. The site will need to be restored from a backup

3. Go to Components ➝ Joomla Update ➝ Options ➝ Update Channel ➝ set Joomla Next ➝ click the button Save & Close.
4. Switch to the tab Live Update ➝ enable the checkbox “Do you wish to ignore the warnings about potentially incompatible plugins and to proceed with the upgrade?” click the button Install the Update.

Related articles