ZeroApp Custom Sort problem

Hello.
I have a problem that I can't seem to solve...

I have a ZeroApp.
The ZeroApp has only one category:

Root
Category01

I arranged the items "By Drag and Drop" in the backoffice.
In the Category List layout page, I selected the option "Sort By ->Custom"

SITUATION 01
a) To list all items, in the main menu I have a link to Gridbox Category -> App -> Root.
b) In this situation, on the website, the items don't appear sorted by the Custom type.
(However, if I choose the other sorting types, they all work fine.)
c) The search box I have at the top of the website works correctly if i choose "Category List layout Option".

SITUATION 02
a) In the main menu, I changed the link to Gridbox Category -> App -> Root -> Category01.
b) On the website, the posts now appear sorted by the Custom type. (as i need).
c) But, in this situation, the search box I have at the top of the website works incorrectly because it always displays the list of all existing posts, if i choose "Category List layout Option".

What could be causing this situation?

Conclusion:
In one scenario, the search feature operates effectively, but the custom sorting feature is malfunctioning. Conversely, in the other scenario, the custom sorting feature functions properly, but the search feature is malfunctioning.
Additionally, it's important to note that on the homepage, there is a "recent post plugin" that consistently operates correctly with the "Sort by: Custom" option.
(I fear I may not have been sufficiently explicit...)

Thank you.
Bebst Regards.

Nuno F.

Replies are visible only to logged in members with an active subscription.