404 Error After Joomla 6 Migration

I created a new website in Joomla 6 to replace an old one. After restoring the backup (Akeba Backup) on the new server, the website is experiencing issues:
- the home page works
- overlay sections don't work
- smooth scrolling doesn't work
- in the backend, every page clicked for editing returns a 404 error.
In the gridbox, all pages and applications are visible, but attempting to click results in a 404.

I also noticed that the subpage addresses on the working server where I created the website are shorter.

Replies are visible only to logged in members with an active subscription.