Forms publish/unpublish icon greyed out although corresponding buttons shown and active

This is about Forms 2.1 and 2.2.
I have the need for specific Joomla users to be able to export form submissions and to publish/unpublish forms, but not work with forms otherwise. In support of this, I have created a new Joomla group and an access level, both called "Forms-User". I have then added said users to the new group. This allows them to login into the Joomla backend as desired, and export the forms submissions. So far, so good.

There is, however, a small error in the forms admin display. These users are allowed to publish/unpublish forms via corresponding button at the top, but the "publish/unpublish" icon (the "eye") is grayed out and shown as crossed eye (i.e. suggesting the form is unpublished). This is no different whether the form actually is in the published or unpublished state.

Moving the mouse over the icon changes the pointer to the "hand", but a click does not do anything with respect to the publishing state.

I have granted (allowed) to "Access Admin Interface" and "Edit State" in the Joomla permission setting for category "Forms* and group "Forms-User". This allows what is desired, including publish/unpublish.

I have also tried to grant (allow) to all items in the list, which then allows the users to also modify the forms, delete, etc. But the "eye" icon is still not shown correctly and a click does not do anything.

Regards
Peter

Replies are visible only to logged in members with an active subscription.