Cannot update BAForms

My J4 site shows BaForms is at version 2.1.3.1 in Extensions >> Update but in Components >> Forms >> About it shows as version 2.2.1
As a result I see an update is required due to the first notice above.
If I try to UPDATE to 2.2.1 via Extensions >> Update , I see this error:
Failed to extract file: login
If I try to manually install ver 2.2.1 via Extensions >> Install I see these errors:
JInstaller: :Install: Error SQL Duplicate column name 'button_font_size'
Extension installation stopped.
Package Update: There was an error installing an extension: com_baforms.zip
danger
Error installing package

Please advise!?

Chris

Replies are visible only to logged in members with an active subscription.