Joomla Technical Requirements

To start working with Joomla!CMS you need to be sure, that your web hosting or localhost meets Joomla Technical Requirements.

Hosting Requirements:

  • PHP 5.3.10 + (5.4 + recommended);
  • MySQL 5.1 + (5.1 + recommended);
  • Apache 2.x + (2.x + recommended).

MySQL database Requirements:

  • Database name;
  • Database user and password;

Browser Requirements:

  • Internet Explorer 9 +;
  • Firefox;
  • Safari;
  • Chrome;
  • Opera.

To get correct working and displaying of your Joomla website, we recommend to follow this Joomla System Requirements.


Check other Joomla tutorials to get more Knowledge.